Are you running macOS before Mojave 10.14.4? Do you use command tools?

If you’re running any version of macOS before Mojave 10.14.4, and you use command tools provided separately from macOS itself, then I strongly recommend that you download and install Apple’s Swift 5 Runtime Support for Command Tools if you haven’t done so already.

The reason for this is that command tools using the Swift 5 language used to ship with their own built-in runtime support libraries. As of Mojave 10.14.4 and Xcode 10.2, this ceased. This makes those tools very much smaller, but when run on earlier versions of macOS they rely on finding those support libraries – which weren’t part of macOS then.

If you try running a newer command tool which was built using Swift 5 on a Mac which is running macOS 10.14.3 or earlier and those support libraries haven’t been installed, then the tool will be unable to run. This invariably results in a fatal error, which reads something like dyld: Library not loaded, following which a dylib is named, along the lines of libswift[…].dylib.

It’s much better, if your intend continuing to run that older version of macOS, to download and install the runtime support libraries now. Then you’re prepared and won’t be puzzled when you install a new command tool which appears to be broken. Unfortunately, as far as I can tell, Apple doesn’t allow developers to distribute its installer package with their own tools. So please download and install now, while you remember, and you won’t be caught out.

This doesn’t apply to command tools which are already part of macOS itself, of course, only those supplied by third parties, or with separately installed Apple apps.