<!DOCTYPE html>
<!--[if IE 9]>
<html class="ie9 lt-ie10" lang="en"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!-->
<html lang="en"> <!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, height=device-height, initial-scale=1, user-scalable=no">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://eclecticlight.co/xmlrpc.php">

	<title>Last Week on My Mac: Should Apple have warned users of a vulnerability? &#8211; The Eclectic Light Company</title>
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=eclecticlight.co&amp;id=83108039&amp;t=1521964280&amp;back=https%3A%2F%2Feclecticlight.co%2F2018%2F03%2F25%2Flast-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//eclecticlightdotcom.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="The Eclectic Light Company &raquo; Feed" href="https://eclecticlight.co/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Eclectic Light Company &raquo; Comments Feed" href="https://eclecticlight.co/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Eclectic Light Company &raquo; Last Week on My Mac: Should Apple have warned users of a&nbsp;vulnerability? Comments Feed" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.5-beta1-42868"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyNj9EOgjAMRX/I2UAiPhm/ZYwqg5UttEj4ewdTE9GgL03b3NN7C2NQxneCnQANKrjhajuGMRhPisk6nFbT3jDv4DvmbIsMDUrQplXLtCXv0WnBSgXPspq2MON7jHsKWmYFYWU1OqQo28IoFE9qbusYcdMmfV2WoUdmFSvZgZTU0ehHPJqjpPchCt83CbXQebGR5lfzcTNZwcMZantD0Mwo6eolypQekT3hXyzL5BblmU7ZITvmWZEf8uYOKcPBsQ==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='hive-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Serif%3A400%2C700%2C400italic%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/_static/??-eJx9j+EKwjAMhF/IGgqbzB/is2S1tpWsGU3HXn8tDnQo/ZU7uC+5wDorwzHbmGFa1EyLC1FgDQ9ns4CwCUgqlMjRnI3ICf7DzrIiNpgDx4NRT8KQWmiyI7Er0kFJfdkWhKYuHzF9VCs+s+R3ExCPqd7aZ4vany91+Gh+oOztZAV8B454RKqB+3TTvb5ch153w2sDXweLXA==?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj90KwjAMhV/IrAw6xQvxWWoXS2r/bNoNfXo70At1KARCTr4cTsScgIJ2dUQWttW1Yr49W2d5I34B4MlkVbDzFF6wjqFgKAvr44kcQmXMyjStGZ3jCpciF4/MDVrZvkeiMBHOfzGLJSl9gYxM9y9XXyG5aiiwyOjaAyMsGT6mdnX0h17uh36Qcre1DyuucHk='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://eclecticlightdotcom.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='macOS High Sierra 10.13.3 still leaks encryption passwords in plain&nbsp;text' href='https://eclecticlight.co/2018/03/24/macos-high-sierra-10-13-3-still-leaks-encryption-passwords-in-plain-text/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/" />
<link rel='shortlink' href='https://wp.me/p5CIcf-8u8' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Feclecticlight.co%2F2018%2F03%2F25%2Flast-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Feclecticlight.co%2F2018%2F03%2F25%2Flast-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Last Week on My Mac: Should Apple have warned users of a vulnerability?" />
<meta property="og:url" content="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/" />
<meta property="og:description" content="Did Apple keep quiet for more than 3 months about the leak of encryption passphrases into High Sierra&#8217;s log files?" />
<meta property="article:published_time" content="2018-03-25T07:00:40+00:00" />
<meta property="article:modified_time" content="2018-03-24T21:14:21+00:00" />
<meta property="og:site_name" content="The Eclectic Light Company" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@howardnoakley" />
<meta name="twitter:text:title" content="Last Week on My Mac: Should Apple have warned users of a&nbsp;vulnerability?" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@howardnoakley" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s0.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://eclecticlightdotcom.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://eclecticlightdotcom.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://eclecticlight.co/osd.xml" title="The Eclectic Light Company" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="The Eclectic Light Company" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Macs, painting, and more" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://eclecticlight.co/feed/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="Last Week on My Mac: Should Apple have warned users of a&nbsp;vulnerability? | The Eclectic Light Company on WordPress.com" />
<meta name="description" content="Did Apple keep quiet for more than 3 months about the leak of encryption passphrases into High Sierra&#039;s log files?" />
<link rel="amphtml" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
<style type="text/css" id="custom-colors-css">.content-quote blockquote:after{-webkit-border-image:none;-webkit-border-image:none;border-image:none;border-image:none}.sticky:not(.format-quote){color:#fff}.sticky:not(.format-quote) a{color:#fff}.widget_blog_subscription input[type="submit"]{color:#fff}.sticky:not(.format-quote) h1,.sticky:not(.format-quote) h2,.sticky:not(.format-quote) h3,.sticky:not(.format-quote) blockquote,.sticky:not(.format-quote) .dropcap{color:#fff}a,.comment-reply-link{color:#d42a0c}.sticky a{color:#fff}.highlight:before,.archive__grid .accent-box,.sticky:not(.format-quote):after,.widget_blog_subscription input[type="submit"]{background-color:#ed303c}.widget_blog_subscription input[type="submit"]{border-color:#ed303c}.content-quote blockquote:before,.content-quote blockquote:before,.widget a:hover,.content-quote blockquote:after{color:#dc1320}</style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=5CIcf&#038;cscache=6&#038;csrev=6" />
		
	<!--[if !IE]><!-->
	<script>
		if (/*@cc_on!@*/false) {
			document.documentElement.className += ' ie10';
		}
	</script>
	<!--<![endif]-->
</head>

<body class="post-template-default single single-post postid-32620 single-format-standard mp6 customizer-styles-applied has_sidebar has-site-logo highlander-enabled highlander-dark custom-colors">
<div id="page" class="hfeed site">

	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">

		<div class="container">
			<div class="site-branding">
				<a href="https://eclecticlight.co/" class="site-logo-link" rel="home"><img width="103" height="93" src="https://eclecticlightdotcom.files.wordpress.com/2015/01/eclecticlightlogo-e1421784280911.png?w=103" class="site-logo attachment-hive-site-logo" alt="" data-size="hive-site-logo" data-attachment-id="79" data-permalink="https://eclecticlight.co/eclecticlightlogo/" data-orig-file="https://eclecticlightdotcom.files.wordpress.com/2015/01/eclecticlightlogo-e1421784280911.png" data-orig-size="103,93" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EclecticLightLogo" data-image-description="" data-medium-file="https://eclecticlightdotcom.files.wordpress.com/2015/01/eclecticlightlogo-e1421784280911.png?w=103" data-large-file="https://eclecticlightdotcom.files.wordpress.com/2015/01/eclecticlightlogo-e1421784280911.png?w=103" /></a>
				<h1 class="site-title site-title--small">
					<a href="https://eclecticlight.co/" rel="home">
						The Eclectic Light Company					</a>
				</h1>

				<div class="site-description">
					<span class="site-description-text">Macs, painting, and more</span>
				</div>
			</div>

			<nav id="site-navigation" class="main-navigation" role="navigation">
				<h5 class="screen-reader-text">Main navigation</h5>
									<button class="navigation__trigger">
						<i class="fa fa-bars"></i><span class="screen-reader-text">Menu</span>
					</button>
				<ul id="menu-short" class="nav  nav--main"><li id="menu-item-26484" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26484"><a href="https://eclecticlight.co/downloads/">Downloads</a></li>
<li id="menu-item-26486" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26486"><a href="https://eclecticlight.co/mac-problem-solving/">Mac problems</a></li>
<li id="menu-item-26485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26485"><a href="https://eclecticlight.co/painting-topics/">Art</a></li>
<li id="menu-item-26489" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-26489"><a href="https://eclecticlight.co/category/macs/">Macs</a></li>
<li id="menu-item-26490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26490"><a href="https://eclecticlight.co/category/painting/">Painting</a></li>
<li id="menu-item-26491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26491"><a href="https://eclecticlight.co/category/general/">General</a></li>
<li id="menu-item-26492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26492"><a href="https://eclecticlight.co/category/life/">Life</a></li>
</ul>			</nav><!-- #site-navigation -->
		</div>

	</header><!-- #masthead -->

	<div id="content" class="site-content">

		<div class="container">
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

			
<article id="post-32620" class="post-32620 post type-post status-publish format-standard hentry category-macs category-technology tag-bug tag-disk-utility tag-encryption tag-high-sierra tag-log tag-logarchive tag-macos-10-13 tag-privacy tag-security tag-vulnerability ">
	
	<header class="entry-header">

		<div class="entry-meta">
			<span class="posted-by"> <span class="author vcard">
					<a class="url fn n" href="https://eclecticlight.co/author/hoakley/">hoakley
					</a>
				</span></span>
<span class="posted-on"><a href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/" rel="bookmark"><time class="entry-date published" datetime="2018-03-25T07:00:40+00:00">March 25, 2018</time></a></span>				<span class="cat-links">
					<a href="https://eclecticlight.co/category/macs/" rel="category tag">Macs</a>, <a href="https://eclecticlight.co/category/technology/" rel="category tag">Technology</a>				</span>
					</div>
		<h1 class="entry-title"><strong>Last Week on My Mac:</strong><em> Should Apple have warned users of a&nbsp;vulnerability?</em>
</h1>
	</header><!-- .entry-header -->

	
		<div class="entry-content" data-first_letter="A">
		<p>At first sight, it might look as if the vulnerability discovered by Sarah Edwards last week, in which passphrases for encrypted APFS volumes were written in plain text to the log, was not only another serious blunder in High Sierra, but also an alarming failure to warn users. Having <a href="https://eclecticlight.co/2018/03/23/is-the-unified-log-private-or-a-vulnerability/">dug around a bit</a> and <a href="https://eclecticlight.co/2018/03/24/macos-high-sierra-10-13-3-still-leaks-encryption-passwords-in-plain-text/">a bit more</a>, I&#8217;m beginning to think that Apple may have been as surprised as we were to hear about the bug.</p>
<p>The basic facts are open to interpretation and misinterpretation.</p>
<p><strong>Guilty?</strong></p>
<p>From its release as macOS 10.13, and possibly through the beta releases too, High Sierra&#8217;s Disk Utility happily wrote the plaintext passphrase of each APFS encrypted volume which it created into its unified log. Anyone with local access to that Mac as an admin user could then extract the passphrase from the log, and use it to gain access to the encrypted volume.</p>
<p>This vulnerability remained in Disk Utility (and the tools which it uses to perform APFS operations, notably <code>diskmanagementd</code>) through macOS 10.13.1, which included the Supplemental Update of 5 October, 10.13.1 itself on 31 October, Security Update 2017-001 on 29 November, and wasn&#8217;t fixed until macOS 10.13.2 on 6 December 2017.</p>
<p>Despite searching the security release notes for those updates, I can find no mention of this bug and vulnerability, nor of it being fixed in 10.13.2. The release notes for 10.13.2 have been well-maintained since their release, receiving updates on 21 December 2017, 5 January 2018, 10 January 2018, 11 January 2018, 22 January 2018, 14 February 2018, and 14 March 2018 (which seems an exceptional circumstance in itself).</p>
<p>I have been unable to find any warning published by Apple of the fact that the logs of a large number of Macs would have contained encryption passphrases in plaintext.</p>
<p>If you want to jump to a conclusion, it might be that Apple thought that, as it had fixed the bug in 10.13.2 and no one had reported it, no one was aware. As unified log files are usually deleted automatically after about twenty days, by about Christmas all those plaintext passphrases would have vanished, and no one would be any the wiser.</p>
<p>Except, of course, that anyone who hadn&#8217;t updated to 10.13.2 would still have the vulnerability, and anyone who made a logarchive of their log before the passphrases were aged out would have retained those leaked passphrases in the logarchive. And, as we <a href="https://eclecticlight.co/2018/03/24/macos-high-sierra-10-13-3-still-leaks-encryption-passwords-in-plain-text/">now know</a>, the bug was only &#8216;fixed&#8217; when creating a new volume; erase an existing APFS volume to encrypt it and the bug persists even in 10.13.3.</p>
<p><strong>Innocent?</strong></p>
<p>I think that there is an alternative account which is far more probable, in which Apple was unaware of this vulnerability until Sarah Edwards discovered it on 21 March 2018.</p>
<p>Disk Utility and StorageKit were little more than kludges in the early releases of High Sierra. The Supplemental Update of 5 October fixed a glaring vulnerability which could reveal encryption passphrases, and a number of other serious bugs were fixed in 10.13.1, although none were listed in its sparse release notes. The version of Disk Utility which fixed this particular vulnerability was 17.0 (1635), compared with 17.0 (337) in 10.13.1. For the build number to have risen from 337 to 1635, Apple&#8217;s engineers have been building long and hard.</p>
<p><a href="https://eclecticlight.co/2018/03/23/is-the-unified-log-private-or-a-vulnerability/">Looking at the log entries</a> made by these initial versions of Disk Utility and <code>diskmanagementd</code>, they hand off the three key steps in creating an APFS encrypted volume to external tools: first to <code>newfs_hfs</code>, presumably to initialise the disk, then to <code>newfs_apfs</code> to create the APFS Container, and finally to <code>newfs_apfs</code> a second time to create the encrypted volume.</p>
<p>That third step appears to have been a kludge, which was replaced by a more secure mechanism in Disk Utility 17.0 (1635), in 10.13.2, which only performs the first two steps using an &#8216;open&#8217; <code>execve()</code> call.</p>
<p>I suspect that the engineers responsible for fixing those early releases of Disk Utility were either unaware that the third step wrote the passphrase in plain text to the log, or were unmindful of the impact of so doing. I think it most probable that they improved that third step to turn what had been an interim kludge into a better and more lasting solution, not specifically to prevent the leaking of the passphrase. Furthermore, they appear to have forgotten that encrypting an existing volume uses very similar code, and haven&#8217;t got round to securing that yet.</p>
<p>Supporting my contention is the fact that the fix, as implemented, only addresses half of the bug, in which the volume encryption should not have proceeded through this &#8216;open&#8217; calling of <code>newfs_apfs</code>. The other half of the bug is that the <code>execve()</code> call from <code>diskmanagementd</code> should not have deliberately made public its dynamic string, which would by default have been censored from the log entry. That clearly remains, as it is still <a href="https://eclecticlight.co/2018/03/23/is-the-unified-log-private-or-a-vulnerability/">the behaviour shown</a> in the first two steps in 10.13.3, and is in all three when encrypting an existing volume.</p>
<p>I think that Apple fixed this vulnerability by serendipity, in the course of fixing other bugs in Disk Utility, and therefore remained unaware of this large leak of passphrases until 21 March, more than three months later, when Sarah Edwards discovered it.</p>
<p>Apple still needs to come clean and explain fully to users what happened, what the consequences are now, and when the remaining lesser bug will be fixed too. However, there is a world of difference between Apple having been fully aware of those consequences for around four months and deliberately keeping quiet about the issues, and learning about them a few days ago. I hope that my confidence is not misplaced.</p>
<div id="jp-post-flair" class="sharedaddy sharedaddy-dark sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-32620" class="share-twitter sd-button share-icon" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-32620" class="share-facebook sd-button share-icon" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-32620" class="share-pinterest sd-button share-icon" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-32620" class="share-google-plus-1 sd-button share-icon" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/?share=email" target="_blank" title="Click to email"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-83108039-32620-5ab754f882b6e' data-src='//widgets.wp.com/likes/index.html?ver=20180319#blog_id=83108039&amp;post_id=32620&amp;origin=eclecticlightdotcom.wordpress.com&amp;obj_id=83108039-32620-5ab754f882b6e' data-name='like-post-frame-83108039-32620-5ab754f882b6e'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>	</div><!-- .entry-content -->

	
	<footer class="entry-footer">
		Posted in <a href="https://eclecticlight.co/category/macs/" rel="category tag">Macs</a>, <a href="https://eclecticlight.co/category/technology/" rel="category tag">Technology</a> and tagged <a href="https://eclecticlight.co/tag/bug/" rel="tag">bug</a>, <a href="https://eclecticlight.co/tag/disk-utility/" rel="tag">Disk Utility</a>, <a href="https://eclecticlight.co/tag/encryption/" rel="tag">encryption</a>, <a href="https://eclecticlight.co/tag/high-sierra/" rel="tag">High Sierra</a>, <a href="https://eclecticlight.co/tag/log/" rel="tag">log</a>, <a href="https://eclecticlight.co/tag/logarchive/" rel="tag">logarchive</a>, <a href="https://eclecticlight.co/tag/macos-10-13/" rel="tag">macOS 10.13</a>, <a href="https://eclecticlight.co/tag/privacy/" rel="tag">privacy</a>, <a href="https://eclecticlight.co/tag/security/" rel="tag">security</a>, <a href="https://eclecticlight.co/tag/vulnerability/" rel="tag">vulnerability</a>. Bookmark the <a href="https://eclecticlight.co/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/" rel="bookmark">permalink</a>.	</footer><!-- .entry-footer -->

</article><!-- #post-## --><aside>
	<div id="comments" class="comments-area  no-comments">
		<div class="comments-area-title">
			<h2 class="comments-title"><span class="comment-number  comment-number--dark  no-comments">i</span>There are no comments</h2>
			<a class="comments_add-comment" href="#reply-title">Add yours</a>		</div>
		
	</div>
	<!-- #comments .comments-area -->
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://eclecticlight.co/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="bcbfe88b00" /><input type="hidden" name="_wp_http_referer" value="/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='32620' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="98b9d73758" /></p>
<input type="hidden" name="genseq" value="1521964280" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="109"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</aside>
		</main><!-- #main -->
	</div><!-- #primary -->


<div id="secondary" class="sidebar  sidebar--main" role="complementary">
	<aside id="nav_menu-3" class="widget widget_nav_menu"><h1 class="widget-title">Quick Links</h1><div class="menu-widget-container"><ul id="menu-widget" class="menu"><li id="menu-item-30236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30236"><a href="https://eclecticlight.co/downloads/">Downloads</a></li>
<li id="menu-item-30238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30238"><a href="https://eclecticlight.co/mac-problem-solving/">Mac problem-solving</a></li>
<li id="menu-item-30286" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30286"><a href="https://eclecticlight.co/extended-attributes-xattrs/">Extended attributes (xattrs)</a></li>
<li id="menu-item-30237" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30237"><a href="https://eclecticlight.co/painting-topics/">Painting topics</a></li>
<li id="menu-item-30239" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30239"><a href="https://eclecticlight.co/category/painting/">Painting</a></li>
<li id="menu-item-30240" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30240"><a href="https://eclecticlight.co/category/life/">Life</a></li>
<li id="menu-item-30241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30241"><a href="https://eclecticlight.co/category/language/">Language</a></li>
</ul></div></aside><aside id="search-4" class="widget widget_search"><h1 class="widget-title">Search</h1><form role="search" method="get" class="search-form" action="https://eclecticlight.co/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside><aside id="archives-4" class="widget widget_archive"><h1 class="widget-title">Monthly archives</h1>		<ul>
			<li><a href='https://eclecticlight.co/2018/03/'>March 2018</a>&nbsp;(54)</li>
	<li><a href='https://eclecticlight.co/2018/02/'>February 2018</a>&nbsp;(67)</li>
	<li><a href='https://eclecticlight.co/2018/01/'>January 2018</a>&nbsp;(83)</li>
	<li><a href='https://eclecticlight.co/2017/12/'>December 2017</a>&nbsp;(94)</li>
	<li><a href='https://eclecticlight.co/2017/11/'>November 2017</a>&nbsp;(73)</li>
	<li><a href='https://eclecticlight.co/2017/10/'>October 2017</a>&nbsp;(86)</li>
	<li><a href='https://eclecticlight.co/2017/09/'>September 2017</a>&nbsp;(92)</li>
	<li><a href='https://eclecticlight.co/2017/08/'>August 2017</a>&nbsp;(69)</li>
	<li><a href='https://eclecticlight.co/2017/07/'>July 2017</a>&nbsp;(81)</li>
	<li><a href='https://eclecticlight.co/2017/06/'>June 2017</a>&nbsp;(76)</li>
	<li><a href='https://eclecticlight.co/2017/05/'>May 2017</a>&nbsp;(90)</li>
	<li><a href='https://eclecticlight.co/2017/04/'>April 2017</a>&nbsp;(76)</li>
	<li><a href='https://eclecticlight.co/2017/03/'>March 2017</a>&nbsp;(79)</li>
	<li><a href='https://eclecticlight.co/2017/02/'>February 2017</a>&nbsp;(65)</li>
	<li><a href='https://eclecticlight.co/2017/01/'>January 2017</a>&nbsp;(76)</li>
	<li><a href='https://eclecticlight.co/2016/12/'>December 2016</a>&nbsp;(75)</li>
	<li><a href='https://eclecticlight.co/2016/11/'>November 2016</a>&nbsp;(68)</li>
	<li><a href='https://eclecticlight.co/2016/10/'>October 2016</a>&nbsp;(76)</li>
	<li><a href='https://eclecticlight.co/2016/09/'>September 2016</a>&nbsp;(78)</li>
	<li><a href='https://eclecticlight.co/2016/08/'>August 2016</a>&nbsp;(70)</li>
	<li><a href='https://eclecticlight.co/2016/07/'>July 2016</a>&nbsp;(74)</li>
	<li><a href='https://eclecticlight.co/2016/06/'>June 2016</a>&nbsp;(66)</li>
	<li><a href='https://eclecticlight.co/2016/05/'>May 2016</a>&nbsp;(71)</li>
	<li><a href='https://eclecticlight.co/2016/04/'>April 2016</a>&nbsp;(67)</li>
	<li><a href='https://eclecticlight.co/2016/03/'>March 2016</a>&nbsp;(71)</li>
	<li><a href='https://eclecticlight.co/2016/02/'>February 2016</a>&nbsp;(68)</li>
	<li><a href='https://eclecticlight.co/2016/01/'>January 2016</a>&nbsp;(90)</li>
	<li><a href='https://eclecticlight.co/2015/12/'>December 2015</a>&nbsp;(96)</li>
	<li><a href='https://eclecticlight.co/2015/11/'>November 2015</a>&nbsp;(103)</li>
	<li><a href='https://eclecticlight.co/2015/10/'>October 2015</a>&nbsp;(119)</li>
	<li><a href='https://eclecticlight.co/2015/09/'>September 2015</a>&nbsp;(115)</li>
	<li><a href='https://eclecticlight.co/2015/08/'>August 2015</a>&nbsp;(117)</li>
	<li><a href='https://eclecticlight.co/2015/07/'>July 2015</a>&nbsp;(117)</li>
	<li><a href='https://eclecticlight.co/2015/06/'>June 2015</a>&nbsp;(105)</li>
	<li><a href='https://eclecticlight.co/2015/05/'>May 2015</a>&nbsp;(111)</li>
	<li><a href='https://eclecticlight.co/2015/04/'>April 2015</a>&nbsp;(119)</li>
	<li><a href='https://eclecticlight.co/2015/03/'>March 2015</a>&nbsp;(69)</li>
	<li><a href='https://eclecticlight.co/2015/02/'>February 2015</a>&nbsp;(54)</li>
	<li><a href='https://eclecticlight.co/2015/01/'>January 2015</a>&nbsp;(39)</li>
		</ul>
		</aside><aside id="wp_tag_cloud-2" class="widget wp_widget_tag_cloud"><h1 class="widget-title">Tags</h1><div style="overflow:hidden"><a href="https://eclecticlight.co/tag/adobe/" class="tag-cloud-link tag-link-29691 tag-link-position-1" style="font-size: 10.31654676259pt;" aria-label="Adobe (65 items)">Adobe</a>
<a href="https://eclecticlight.co/tag/apfs/" class="tag-cloud-link tag-link-16027655 tag-link-position-2" style="font-size: 10.920863309353pt;" aria-label="APFS (74 items)">APFS</a>
<a href="https://eclecticlight.co/tag/apple/" class="tag-cloud-link tag-link-291 tag-link-position-3" style="font-size: 16.964028776978pt;" aria-label="Apple (302 items)">Apple</a>
<a href="https://eclecticlight.co/tag/applescript/" class="tag-cloud-link tag-link-3467 tag-link-position-4" style="font-size: 11.726618705036pt;" aria-label="AppleScript (91 items)">AppleScript</a>
<a href="https://eclecticlight.co/tag/app-store/" class="tag-cloud-link tag-link-5247686 tag-link-position-5" style="font-size: 8.5035971223022pt;" aria-label="App Store (43 items)">App Store</a>
<a href="https://eclecticlight.co/tag/backup/" class="tag-cloud-link tag-link-5469 tag-link-position-6" style="font-size: 11.525179856115pt;" aria-label="backup (87 items)">backup</a>
<a href="https://eclecticlight.co/tag/blake/" class="tag-cloud-link tag-link-121850 tag-link-position-7" style="font-size: 8.8057553956835pt;" aria-label="Blake (46 items)">Blake</a>
<a href="https://eclecticlight.co/tag/bosch/" class="tag-cloud-link tag-link-95080 tag-link-position-8" style="font-size: 8.3021582733813pt;" aria-label="Bosch (41 items)">Bosch</a>
<a href="https://eclecticlight.co/tag/bugs/" class="tag-cloud-link tag-link-6354 tag-link-position-9" style="font-size: 11.021582733813pt;" aria-label="bugs (77 items)">bugs</a>
<a href="https://eclecticlight.co/tag/chase/" class="tag-cloud-link tag-link-35231 tag-link-position-10" style="font-size: 9.0071942446043pt;" aria-label="Chase (48 items)">Chase</a>
<a href="https://eclecticlight.co/tag/consolation/" class="tag-cloud-link tag-link-378938 tag-link-position-11" style="font-size: 12.431654676259pt;" aria-label="Consolation (107 items)">Consolation</a>
<a href="https://eclecticlight.co/tag/console/" class="tag-cloud-link tag-link-2611 tag-link-position-12" style="font-size: 12.935251798561pt;" aria-label="Console (120 items)">Console</a>
<a href="https://eclecticlight.co/tag/cezanne/" class="tag-cloud-link tag-link-316577 tag-link-position-13" style="font-size: 8.8057553956835pt;" aria-label="Cézanne (46 items)">Cézanne</a>
<a href="https://eclecticlight.co/tag/degas/" class="tag-cloud-link tag-link-244922 tag-link-position-14" style="font-size: 8.2014388489209pt;" aria-label="Degas (40 items)">Degas</a>
<a href="https://eclecticlight.co/tag/diagnosis/" class="tag-cloud-link tag-link-25008 tag-link-position-15" style="font-size: 9.7122302158273pt;" aria-label="diagnosis (56 items)">diagnosis</a>
<a href="https://eclecticlight.co/tag/disk-utility/" class="tag-cloud-link tag-link-2512263 tag-link-position-16" style="font-size: 9.6115107913669pt;" aria-label="Disk Utility (55 items)">Disk Utility</a>
<a href="https://eclecticlight.co/tag/eastgate/" class="tag-cloud-link tag-link-309691 tag-link-position-17" style="font-size: 10.115107913669pt;" aria-label="Eastgate (62 items)">Eastgate</a>
<a href="https://eclecticlight.co/tag/el-capitan/" class="tag-cloud-link tag-link-266601 tag-link-position-18" style="font-size: 15.956834532374pt;" aria-label="El Capitan (238 items)">El Capitan</a>
<a href="https://eclecticlight.co/tag/extended-attributes/" class="tag-cloud-link tag-link-3013936 tag-link-position-19" style="font-size: 10.719424460432pt;" aria-label="extended attributes (71 items)">extended attributes</a>
<a href="https://eclecticlight.co/tag/finder/" class="tag-cloud-link tag-link-55715 tag-link-position-20" style="font-size: 10.31654676259pt;" aria-label="Finder (65 items)">Finder</a>
<a href="https://eclecticlight.co/tag/flash/" class="tag-cloud-link tag-link-456 tag-link-position-21" style="font-size: 11.021582733813pt;" aria-label="Flash (77 items)">Flash</a>
<a href="https://eclecticlight.co/tag/gatekeeper/" class="tag-cloud-link tag-link-102026 tag-link-position-22" style="font-size: 11.726618705036pt;" aria-label="Gatekeeper (90 items)">Gatekeeper</a>
<a href="https://eclecticlight.co/tag/hard-drive/" class="tag-cloud-link tag-link-52805 tag-link-position-23" style="font-size: 9.5107913669065pt;" aria-label="hard drive (54 items)">hard drive</a>
<a href="https://eclecticlight.co/tag/high-sierra/" class="tag-cloud-link tag-link-1041249 tag-link-position-24" style="font-size: 15.856115107914pt;" aria-label="High Sierra (231 items)">High Sierra</a>
<a href="https://eclecticlight.co/tag/history-of-painting/" class="tag-cloud-link tag-link-9273791 tag-link-position-25" style="font-size: 11.021582733813pt;" aria-label="history of painting (76 items)">history of painting</a>
<a href="https://eclecticlight.co/tag/hypermedia/" class="tag-cloud-link tag-link-139403 tag-link-position-26" style="font-size: 8pt;" aria-label="hypermedia (38 items)">hypermedia</a>
<a href="https://eclecticlight.co/tag/hypertext/" class="tag-cloud-link tag-link-188353 tag-link-position-27" style="font-size: 9.1079136690647pt;" aria-label="hypertext (49 items)">hypertext</a>
<a href="https://eclecticlight.co/tag/icloud/" class="tag-cloud-link tag-link-10036452 tag-link-position-28" style="font-size: 8.8057553956835pt;" aria-label="iCloud (46 items)">iCloud</a>
<a href="https://eclecticlight.co/tag/impressionism/" class="tag-cloud-link tag-link-214337 tag-link-position-29" style="font-size: 14.143884892086pt;" aria-label="Impressionism (158 items)">Impressionism</a>
<a href="https://eclecticlight.co/tag/ios/" class="tag-cloud-link tag-link-324281 tag-link-position-30" style="font-size: 10.215827338129pt;" aria-label="iOS (64 items)">iOS</a>
<a href="https://eclecticlight.co/tag/landscape/" class="tag-cloud-link tag-link-11201 tag-link-position-31" style="font-size: 15.553956834532pt;" aria-label="landscape (216 items)">landscape</a>
<a href="https://eclecticlight.co/tag/language-2/" class="tag-cloud-link tag-link-1630242 tag-link-position-32" style="font-size: 9.1079136690647pt;" aria-label="language (49 items)">language</a>
<a href="https://eclecticlight.co/tag/log/" class="tag-cloud-link tag-link-12657 tag-link-position-33" style="font-size: 13.438848920863pt;" aria-label="log (135 items)">log</a>
<a href="https://eclecticlight.co/tag/logs/" class="tag-cloud-link tag-link-17958 tag-link-position-34" style="font-size: 12.935251798561pt;" aria-label="logs (118 items)">logs</a>
<a href="https://eclecticlight.co/tag/mac/" class="tag-cloud-link tag-link-808 tag-link-position-35" style="font-size: 14.647482014388pt;" aria-label="Mac (177 items)">Mac</a>
<a href="https://eclecticlight.co/tag/macos/" class="tag-cloud-link tag-link-55368 tag-link-position-36" style="font-size: 19.280575539568pt;" aria-label="macOS (517 items)">macOS</a>
<a href="https://eclecticlight.co/tag/macos-10-12/" class="tag-cloud-link tag-link-435378828 tag-link-position-37" style="font-size: 14.647482014388pt;" aria-label="macOS 10.12 (175 items)">macOS 10.12</a>
<a href="https://eclecticlight.co/tag/macos-10-13/" class="tag-cloud-link tag-link-507422264 tag-link-position-38" style="font-size: 11.122302158273pt;" aria-label="macOS 10.13 (79 items)">macOS 10.13</a>
<a href="https://eclecticlight.co/tag/malware/" class="tag-cloud-link tag-link-15593 tag-link-position-39" style="font-size: 10.920863309353pt;" aria-label="malware (75 items)">malware</a>
<a href="https://eclecticlight.co/tag/metamorphoses/" class="tag-cloud-link tag-link-3193982 tag-link-position-40" style="font-size: 11.928057553957pt;" aria-label="Metamorphoses (94 items)">Metamorphoses</a>
<a href="https://eclecticlight.co/tag/monet/" class="tag-cloud-link tag-link-257825 tag-link-position-41" style="font-size: 10.920863309353pt;" aria-label="Monet (75 items)">Monet</a>
<a href="https://eclecticlight.co/tag/moreau/" class="tag-cloud-link tag-link-228553 tag-link-position-42" style="font-size: 10.215827338129pt;" aria-label="Moreau (63 items)">Moreau</a>
<a href="https://eclecticlight.co/tag/mrt/" class="tag-cloud-link tag-link-531971 tag-link-position-43" style="font-size: 8pt;" aria-label="MRT (38 items)">MRT</a>
<a href="https://eclecticlight.co/tag/myth/" class="tag-cloud-link tag-link-21945 tag-link-position-44" style="font-size: 14.143884892086pt;" aria-label="myth (158 items)">myth</a>
<a href="https://eclecticlight.co/tag/narrative/" class="tag-cloud-link tag-link-29521 tag-link-position-45" style="font-size: 17.568345323741pt;" aria-label="narrative (349 items)">narrative</a>
<a href="https://eclecticlight.co/tag/os-x/" class="tag-cloud-link tag-link-2438 tag-link-position-46" style="font-size: 17.669064748201pt;" aria-label="OS X (351 items)">OS X</a>
<a href="https://eclecticlight.co/tag/os-x-10-11/" class="tag-cloud-link tag-link-256692283 tag-link-position-47" style="font-size: 10.920863309353pt;" aria-label="OS X 10.11 (75 items)">OS X 10.11</a>
<a href="https://eclecticlight.co/tag/ovid/" class="tag-cloud-link tag-link-54993 tag-link-position-48" style="font-size: 12.834532374101pt;" aria-label="Ovid (116 items)">Ovid</a>
<a href="https://eclecticlight.co/tag/painting-2/" class="tag-cloud-link tag-link-34917973 tag-link-position-49" style="font-size: 22pt;" aria-label="painting (955 items)">painting</a>
<a href="https://eclecticlight.co/tag/pissarro/" class="tag-cloud-link tag-link-256963 tag-link-position-50" style="font-size: 9.3093525179856pt;" aria-label="Pissarro (52 items)">Pissarro</a>
<a href="https://eclecticlight.co/tag/post-impressionism/" class="tag-cloud-link tag-link-214338 tag-link-position-51" style="font-size: 9.0071942446043pt;" aria-label="Post-impressionism (48 items)">Post-impressionism</a>
<a href="https://eclecticlight.co/tag/poussin/" class="tag-cloud-link tag-link-2749132 tag-link-position-52" style="font-size: 9.2086330935252pt;" aria-label="Poussin (50 items)">Poussin</a>
<a href="https://eclecticlight.co/tag/pre-raphaelite/" class="tag-cloud-link tag-link-214336 tag-link-position-53" style="font-size: 9.3093525179856pt;" aria-label="Pre-Raphaelite (51 items)">Pre-Raphaelite</a>
<a href="https://eclecticlight.co/tag/privacy/" class="tag-cloud-link tag-link-3279 tag-link-position-54" style="font-size: 10.014388489209pt;" aria-label="privacy (60 items)">privacy</a>
<a href="https://eclecticlight.co/tag/realism/" class="tag-cloud-link tag-link-76738 tag-link-position-55" style="font-size: 8.2014388489209pt;" aria-label="realism (40 items)">realism</a>
<a href="https://eclecticlight.co/tag/rubens/" class="tag-cloud-link tag-link-2032860 tag-link-position-56" style="font-size: 10.41726618705pt;" aria-label="Rubens (67 items)">Rubens</a>
<a href="https://eclecticlight.co/tag/safari/" class="tag-cloud-link tag-link-139 tag-link-position-57" style="font-size: 8.3021582733813pt;" aria-label="Safari (41 items)">Safari</a>
<a href="https://eclecticlight.co/tag/sargent/" class="tag-cloud-link tag-link-1034206 tag-link-position-58" style="font-size: 10.014388489209pt;" aria-label="Sargent (61 items)">Sargent</a>
<a href="https://eclecticlight.co/tag/scripting/" class="tag-cloud-link tag-link-2929 tag-link-position-59" style="font-size: 11.424460431655pt;" aria-label="scripting (84 items)">scripting</a>
<a href="https://eclecticlight.co/tag/security/" class="tag-cloud-link tag-link-801 tag-link-position-60" style="font-size: 18.676258992806pt;" aria-label="security (445 items)">security</a>
<a href="https://eclecticlight.co/tag/sierra/" class="tag-cloud-link tag-link-105398 tag-link-position-61" style="font-size: 18.776978417266pt;" aria-label="Sierra (456 items)">Sierra</a>
<a href="https://eclecticlight.co/tag/sip/" class="tag-cloud-link tag-link-32527 tag-link-position-62" style="font-size: 8.9064748201439pt;" aria-label="SIP (47 items)">SIP</a>
<a href="https://eclecticlight.co/tag/storyspace/" class="tag-cloud-link tag-link-6863932 tag-link-position-63" style="font-size: 10.920863309353pt;" aria-label="Storyspace (75 items)">Storyspace</a>
<a href="https://eclecticlight.co/tag/swift/" class="tag-cloud-link tag-link-596263 tag-link-position-64" style="font-size: 12.431654676259pt;" aria-label="Swift (105 items)">Swift</a>
<a href="https://eclecticlight.co/tag/symbolism/" class="tag-cloud-link tag-link-197858 tag-link-position-65" style="font-size: 8.5035971223022pt;" aria-label="symbolism (43 items)">symbolism</a>
<a href="https://eclecticlight.co/tag/time-machine/" class="tag-cloud-link tag-link-280009 tag-link-position-66" style="font-size: 12.73381294964pt;" aria-label="Time Machine (115 items)">Time Machine</a>
<a href="https://eclecticlight.co/tag/tinderbox/" class="tag-cloud-link tag-link-824400 tag-link-position-67" style="font-size: 8.6043165467626pt;" aria-label="Tinderbox (44 items)">Tinderbox</a>
<a href="https://eclecticlight.co/tag/turner/" class="tag-cloud-link tag-link-734026 tag-link-position-68" style="font-size: 11.021582733813pt;" aria-label="Turner (76 items)">Turner</a>
<a href="https://eclecticlight.co/tag/update/" class="tag-cloud-link tag-link-3251 tag-link-position-69" style="font-size: 16.863309352518pt;" aria-label="update (291 items)">update</a>
<a href="https://eclecticlight.co/tag/upgrade/" class="tag-cloud-link tag-link-8683 tag-link-position-70" style="font-size: 9.7122302158273pt;" aria-label="upgrade (57 items)">upgrade</a>
<a href="https://eclecticlight.co/tag/van-gogh/" class="tag-cloud-link tag-link-20339 tag-link-position-71" style="font-size: 8.5035971223022pt;" aria-label="van Gogh (43 items)">van Gogh</a>
<a href="https://eclecticlight.co/tag/vulnerability/" class="tag-cloud-link tag-link-20650 tag-link-position-72" style="font-size: 8.9064748201439pt;" aria-label="vulnerability (47 items)">vulnerability</a>
<a href="https://eclecticlight.co/tag/xattr/" class="tag-cloud-link tag-link-3925058 tag-link-position-73" style="font-size: 10.719424460432pt;" aria-label="xattr (72 items)">xattr</a>
<a href="https://eclecticlight.co/tag/xcode/" class="tag-cloud-link tag-link-176525 tag-link-position-74" style="font-size: 11.625899280576pt;" aria-label="Xcode (89 items)">Xcode</a>
<a href="https://eclecticlight.co/tag/xprotect/" class="tag-cloud-link tag-link-10864411 tag-link-position-75" style="font-size: 10.014388489209pt;" aria-label="XProtect (61 items)">XProtect</a></div></aside><aside id="blog-stats-2" class="widget widget_blog-stats"><h1 class="widget-title">Statistics</h1>		<ul>
			<li>1,449,103 hits</li>
		</ul>
		</aside></div><!-- #secondary --></div><!-- .container -->

</div><!-- #content -->

<footer id="colophon" class="site-footer" role="contentinfo">
	<div class="container">
		<div class="grid">
			<div class="grid__item  site-info">
				<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a>
				
							</div><!-- .site-info -->

			<div class="grid__item  footer-navigation">
				<nav><h5 class="screen-reader-text">Footer navigation</h5><ul id="menu-main" class="nav  nav--footer"><li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-23"><a href="https://eclecticlight.co/category/macs/">Macs</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://eclecticlight.co/category/painting/">Painting</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://eclecticlight.co/category/language/">Language</a></li>
<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-78"><a href="https://eclecticlight.co/category/technology/">Tech</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://eclecticlight.co/category/life/">Life</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22"><a href="https://eclecticlight.co/category/general/">General</a></li>
<li id="menu-item-20571" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20571"><a href="https://eclecticlight.co/downloads/">Downloads</a></li>
<li id="menu-item-364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-364"><a href="https://eclecticlight.co/mac-problem-solving/">Mac problem-solving</a></li>
<li id="menu-item-30283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30283"><a href="https://eclecticlight.co/extended-attributes-xattrs/">Extended attributes (xattrs)</a></li>
<li id="menu-item-30231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30231"><a href="https://eclecticlight.co/category/xattr/">xattr</a></li>
<li id="menu-item-365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-365"><a href="https://eclecticlight.co/painting-topics/">Painting topics</a></li>
<li id="menu-item-14086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14086"><a href="https://eclecticlight.co/hieronymus-bosch/">Hieronymus Bosch</a></li>
<li id="menu-item-707" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-707"><a href="https://eclecticlight.co/english-language-topics/">English language</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26"><a href="https://eclecticlight.co/about">About</a></li>
</ul></nav>			</div>
		</div>
	</div><!-- .site-footer .container -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<div class="toolbar">
		<div class="toolbar__head">
			<nav id="social-navigation" class="toolbar-navigation" role="navigation">
				<h5 class="screen-reader-text">Secondary navigation</h5>
									<ul class="nav  nav--toolbar">
						<li class="nav__item--search"><a href="#">Search</a></li>
					</ul>
							</nav>
			<!-- #social-navigation -->
		</div>
		<div class="toolbar__body">
						<nav class="navigation post-navigation" role="navigation">
				<h1 class="screen-reader-text">Post navigation</h1>

				<div class="nav-links">
					<div class="nav-home"><a href="https://eclecticlight.co"><i class="fa fa-th-large"></i></a></div><div class="nav-previous"><a href="https://eclecticlight.co/2018/03/24/macos-high-sierra-10-13-3-still-leaks-encryption-passwords-in-plain-text/" rel="prev"><i class="fa fa-long-arrow-left prev-arrow"></i><span>macOS High Sierra 10.13.3 still leaks encryption passwords in plain&nbsp;text</span></a></div><div class="nav-next disabled"><i class="fa fa-long-arrow-right next-arrow"></i></div>				</div>
				<!-- .nav-links -->
			</nav><!-- .navigation -->
				</div>
	</div>
	<div class="overlay--search">
		<div class="overlay__wrapper">
			<form role="search" method="get" class="search-form" action="https://eclecticlight.co/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			<p>Begin typing your search above and press return to search. Press Esc to cancel.</p>
		</div>
		<b class="overlay__close"></b>
	</div>
<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201812y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/eclecticlightdotcom.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/eclecticlightdotcom.wordpress.com\/wp-login.php?action=logout&_wpnonce=b318577852","homeURL":"https:\/\/eclecticlight.co\/","postID":"32620","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/eclecticlight.co\/2018\/03\/25\/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability\/":32620};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2018/03/25/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"83108039","siteName":"The Eclectic Light Company","siteURL":"https:\/\/eclecticlight.co","icon":"<img alt='' src='https:\/\/s1.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"premium\/hive","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/eclecticlightdotcom.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Feclecticlight.co%2F2018%2F03%2F25%2Flast-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability%2F","themeURL":"https:\/\/wordpress.com\/theme\/hive\/","xhrURL":"https:\/\/eclecticlight.co\/wp-admin\/admin-ajax.php","nonce":"48f8f2bf12","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"89a31957c4\" \/>","referer":"https:\/\/eclecticlight.co\/2018\/03\/25\/last-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability\/","canFollow":"1","feedID":"33050143","statusMessage":"","customizeLink":"https:\/\/eclecticlightdotcom.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Feclecticlightdotcom.wordpress.com%2F2018%2F03%2F25%2Flast-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability%2F","postID":"32620","shortlink":"https:\/\/wp.me\/p5CIcf-8u8","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/eclecticlight.co\/32620","statsLink":"https:\/\/wordpress.com\/stats\/post\/32620\/eclecticlight.co","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Hive","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 1,284 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/eclecticlightdotcom.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Feclecticlight.co%2F2018%2F03%2F25%2Flast-week-on-my-mac-should-apple-have-warned-users-of-a-vulnerability%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVkdFOwzAMRX+INBQYe0I88xUoS7zWbZwEO+3Y35MydSqiqtSnWL732PKNviRlY8gQsu5EOxjRQvquOnnQC4kGlfzQYBDtsQfRXwMM0JrgPPCG2Uai0lI3qJvok5YLJtgD/WnMIAbrB3czIJkGxEfjwFWEYc1DRmLg61Ked+cWqJgSA+FAusURtBGB/H/4LrIrKZWNbRyBP36BffwIPlrM130UmfUA5hQZkl+NYfEFxhVdnQxPsWXgUqnpCsZp2L23c0JmY3vZgmzGGCboXm25exSCrJ6rR/1ZLtXnyLThT1GyOnuDrKU1jKGZ3wK901t9eKpfD8eX+tj9ADZlKJ8='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20180319#ver=20180319' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'83108039','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'83108039','v':'wpcom','tz':'0','user_id':'0','post':'32620','subd':'eclecticlightdotcom'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGRVYVNrSFguN3FwSmQ5RGtNX3VQcj1yVzhiflM1THQtLGFdQ2toOXYlWk1OW0cyNVNuU0ttM0FRbUddbVlMTjZ4eUsveXpJUXJUMHxFdXl0YVNBZWh+YzV+TFBwLmE1eXg0dWYrLT9GakpbRmNDVGotZzVTNzVFTDBIdHVqfmFHaS1qfGZEaG11ZCwwRGomOX5RUEVZYkgyNktWPSVoaFBsQ1NuTn4vU3lpb10xUG1Ga2F+OEhDenx6aWVvU3pWVEJYcmxBP0h+akl4c05zc1poZ1ZUZnQ1VUhmMnBnY0tiL3ZKVXhvM3JzRytpMEolRDVVLTQyLGNQZ1YmeUFmaUs0MV94SkE0UGsrWl1laj9fRS4lRlROMFl8NzRsdldleENyW29DSnglcX5z'}]);
_stq.push([ 'clickTrackerInit', '83108039', '32620' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>