Entering Recovery Mode in macOS Sierra: you may need a wired keyboard

Before macOS Sierra, all you had to do to enter Recovery Mode was restart with the Command and R keys held down. Even if you were using a wireless keyboard (an Apple one, at least), this worked flawlessly.

A couple of days ago, I tried this on my iMac17,1 running macOS Sierra 10.12.1. The first time, it shot straight through and started up in normal mode. I thought that perhaps I had not held the keys from early enough in the restart process, so tried again. It shot straight through again. It was only when I connected my Apple Magic Keyboard using its charging cable to a USB port, effectively turning it into a wired USB keyboard, that it picked up my key command and went into Recovery mode.

I have entered this into the list of bugs for 10.12.1: maybe this is what Apple intends for the future, but its documentation does not draw attention to it. Perhaps it is the result of a recent firmware update, or cosmic rays, or …

I have also amended my article about recovery mode to make this clear.